Turing 2 not recognizing cm4 boards
# │forum
d
Posted on Kickstarter comments too and I was thankfully referred to this server. My Board does not seem to recognize any of the four different cm4s I have - I cannot boot sd card or connect to the cm4s in usb mode. I’m using a usb a cable and do not have a battery installed. Admittedly the CM4 boards I have are all the same and have tried using different nodes with usb mode and moving the sd card to different nodes. Also , When I open the web gui none of the boards are listed. Appreciate any types of help!
d
The board are not necessarily going to be listed there, this feature is not completed
Did you power on the nodes?
What LEDs do you see on the board lit? A photo would help
Also, are these modules the Light versions or rMMC versions? eMMC ones cannot be used with the SD card and need to be flashed onto the eMMC
d
Thanks for the response. I did power on the nodes. Tried both through the console and the switch in the board. I do have the eMMC module - but tried the SD card since I haven’t been able to detect the modules in windows. This picture is my latest attempt to get it working with one module in place. Thanks !
Green light on psu side. Red light on rear. Two green lights on adaptor
d
So, like I mentioned, you cannot use the SD cards with the eMMC version of the modules.
To have a module visible under windows, you first need to put it into the flashing mode, please check: https://help.turingpi.com/hc/en-us/articles/8687165986205-Install-OS
Make sure to use the USB_OTG port in the back of the Turing Pi 2 board (next to the HDMI port)
Make sure to use USB A-A cable (USB A-C rarely work)
If you see any troubles with flashing in Node 1, flash the module in other node
d
Thanks - I’ve tried all these steps multiple times. I’ve even bought a new usb a to a cable without success. I was thinking of trying to use a different PC - to see if that matters. I’d rather not buy more cm4 modules given the price / availability, but that maybe my next step too to make sure the modules aren’t bad…
d
I was quite tired when you posted this and noticed just now - never put a board onto an antistatic bag. Antistatic bag's task is to keep static charge outside of the bag, exactly where you put the board at.
The LED indicators look ok
As for the flashing - are you setting node 2 into the device mode and setting USB port for Node 2?
d
Thanks - I actually 3d printed a stand that the board is sitting on. The stand is on the bag 😃.
And I ran ‘tpi -u device -n 2’ Should I have ran something else too?
d
Ok, and you power the node on after you run this command?
I also do not see a network cable connected, but I'm assuming the photo was taken in the different point of time?
d
Yes. I have tried turning the node on before and after running the command.
And you are correct - I usually do have a network cable plugged in
Will be able to try another pc in a little bit when I get home. I really do appreciate your help !
b
have you tried putting the CM4 in slot 1 and seeing what appears on the HDMI port? I think a CM4 with an unflashed eMMC would still show something on HDMI.
d
Interesting - I’ll give that a try. Thanks!
I was thankfully able to get one module successfully flashed after I tried a different pc - but the others not so lucky. Will see if I’m getting output with hdmi.
d
Can you describe "not so lucky"?
d
So I wasn’t able to flash my other modules still - PC wouldn’t recognize them. I decided to use a different usb port and now that worked! So all my modules are currently working! Thanks for the help!
3 Views