Turing Pi 1: RJ45/USB connector doesn’t work — Any...
# │forum
Hi there 👋 I bought a Turing Pi 1 already over a year ago and just recently tried to set it up. Unfortunately it doesn’t work. The CM3+ can’t be reached from the network if attached to the board. The most concerning fact is that the LEDs of the RJ45/USB connector aren’t blinking when a network cable is attached. After having synced with the Turing Pi support I desoldered the old component, cleaned the PCB and soldering a replacement. Still the same effect. No connectivity. To cross-check I tested all CM3+ on an IO board independently and they work just fine. Did anyone else face this issue before? And if so, have you been able to fix it somehow?
I posted the same issue just a few days ago. No replies. There is a reddit post about the issue and multiple people had to return for replacement.
For the Turing Pi 1 version?
Would you mind sharing the Reddit post as well?
> The reply I got back today indicates it's probably the switch itself so they're going to replace it. This sounds like the switch might be the problem and not the RJ45/USB connector.
I agree. The CM3 in position 1 can detect a network adapter, but there is no carrier. I suspect the 7 x SMSC chips are functioning but cannot get link from the Realtek switch. The USB devices I have connected to that USB node receive power, are detected by the operating system, but no comms. All other USB nodes work. There is mention of overheating being an issue, but this is the first time I’ve powered it up, there has been no link from the very beginning and the switch hasn’t felt anything beyond lukewarm. I don’t have the equipment to test or replace/re-solder something this small, so I can only hope they’ll honour a warranty replacement.
Just powered it up again and I was wrong with one or two things. The OS is detecting: 0bda:8153 Realtek RTL8153 Ethernet adapter 0424:ec00 Microchip Technology 9512/9514 Ethernet adapter Also, it only detects USB devices on node 1 (thinking now that this may be by design)
Confirmed. By design. Getting a different module on USB node 2 with USB-Ethernet adapter.
and the MAC address for the Ethernet adapter with NO-CARRIER indicates the vendor is Raspberry Pi Foundation dmesg: [ 13.243929] smsc95xx 1-1.1:1.0 eth0: hardware isn’t capable of remote wakeup [ 13.404530] smsc95xx 1-1.1:1.0 eth0: Link is down
I had somewhat similar issues with my first TP1
Ultimately only slot 3 and 7 ended up working well.
I had to use a USB-Ethernet dongle on some of the other nodes to get network connectivity
My board was ultimately replaced by a fully functional board.
I don’t know if it was a power draw issue, or heating on the switch chip.
On my current TP1 I put a heat sink on the Realtek switch
Mine was that way from first startup. Didn’t have much time to heat up and after reading about heat issues, checked it again and wasn’t remotely warm. Haven’t heard anything back from support. Won’t be buying a TP2. Will be trying to figure out what I’m going to do with 7 CM3s that took years to arrive.
I only have 2x CM3+ to start with
@somethingsomethington you filed a ticket at https://help.turingpi.com/hc/en-us ?
I asked someone on your behalf and that's the response I got myself... it does sound similar to the issue I had on my first TP1. I wish I could do more.
@m99coder which component did you desolder and resolder, the RJ-45 connector or the Realtek Ethernet switch chip?
The RJ-45 connector.
@m99coder see if either of those is similar; I believe they are all symptoms of the same type of issue
@m99coder if you haven't filed a ticket at https://help.turingpi.com/hc/en-us do so ("Submit a request"); I suspect you're way out of warranty but it can't hurt
Way out of warranty, yes. And I changed my setup to use PoE boards in conjunction with CM3+ and a PoE switch. That works just fine for me.
I'm glad you found a solution.
By the way, what are you using your cluster for?
Deploying K3s and playing around with Kubernetes stuff locally.