Turing Pi V1 Master CM3+ issues
# │forum
Greetings, After a long time rest collecting dust, I have started to work on my Turing Pi V1 with seven CM3+ w/8GB eMMC. All of the Pi in the slots are functioning as expected. Now the but.....the slot #1/Master will not flash the eMMC and while the Pi in the slot only the HDMI lights up but the ethernet is not active and all of the USB keyboard ports work. I tried all of them (I might add that the documentation does not indicate the mapping between the Pis and the USB ports. I have swapped multiple CM3s that work fine in any other slot but no USB or network in slot #1. Does anyone have and idea as to what is wrong? Thanks, jt
The USB ports along the back (starting next to the HDMI port) are for node 1, 2, 4, and 6. (Assuming the documentation is correct…) https://help.turingpi.com/hc/en-us/articles/8536791368349-Specs
I don’t know what PC you’re using to flash your eMMC so it may be different. (I used a Mac as Jeff Geerling did.)
Btw, the first TP1 I received only seemed to work on two nodes (forgot which two). I think it was a current drain early production issue. The devs shipped me a second one for free that was much more stable. (Installing a heat sink on the LAN switch chip helped.)
The dotted line shows which pair of USB ports is connected to which node.
I apologize if I have yet failed to address your question.
I used a Compute Module IO Board with PoE from Waveshare connected to a Ubuntu x86 PC. I also used the same Waveshare slead connedted to a MacBook Pro. The CM3s all function when pluged into slots 2-7. It is just the Master slot #1 that can't be used. It appears to boot correctly. The HDMI monitor displays the boot messages and login prompt. The CM3 is not registered on the network all the other CM3s get addresses via dhcp and I can ssh to them. the Master CM3 does not get an address and is absent from the network scan. Since none of the USB posts connect to the Master slot login is not possible. I had not noticed that there are no dotted lines from the Master slot to the USB ports and a closer read of the docs also point out that the Master slot has no USB connection. The issue now appears to be that the Master ethernet is not working. I have verified that the CM3 that doesn't connect to the network in slot #1 works in slots 2-7 and a CM3 that works in slots 2-7 fails in slot #1.
@JohnTucker I apologize if you've already done this... try filing a ticket at https://help.turingpi.com/hc/en-us
in 2020 my TP1 had some issues and after come e-mail communications I got a replacement TP1 that's worked great
it's possible the "warranty" has expired however
@JohnTucker I suspect all are symptoms of the same type of issue.