Replacing Kubenetes node
# │forum
r
Hi, I just received my RK1 and so i have replaced my node 1 cm-4 , I followed the guide to set up the RK1 with ubuntu and kubernetes and it seems to work except for one thing. All of the other nodes i can access ssh using the node#.local but not the new one. my nodes are called turing-node-1 thru 4. I'm wondering what in the network config might cause that ?
I used the raspberry pi image for the cm4's and therubuntu image for the rk1
x
How did you install K8s on the RK1?, eg did you ssh into ubuntu.local?, can you still do this?, if so have you changed the host name from the default “ubuntu” to the new host name eg “turing-node-1” , you can change the hostname by either using “hostnamectl set-hostname ” or by editing the /etc/hostname file directly.. eg sudo nano /etc/hostname
r
I disd the sudo nano /etc/hostname
at the moment the only way to ssh in is to use the ssh user@ipaddress format
node-admin@turing-node-1:/etc$ hostnamectl Static hostname: turing-node-1 Icon name: computer Machine ID: 6815df6c973b422ca13887c6202a65ba Boot ID: 1f9193ad94a646079914218bf33c2256 Operating System: Ubuntu 22.04.4 LTS Kernel: Linux 5.10.160-rockchip Architecture: arm64
x
what about ssh user@ubuntu.local, if that works I suggest a reboot of the node
r
when logged in it shows the correct host name.
I have rebooted the rk1 twice and using ubuntu.local does not resolve
x
are you using a static IP, or DHCP either dynamic or reserved
r
static and its reserved on my main router
I have basically given the new rk1 the same ipaddress as the previous one and the same hostname
and the other cm4 is lying on my desk
is it something to do with mDNS config
x
ok, you have created a host entry in your DHCP server with a reserved IP address?, you will need to delete or update the MAC address associated to the RK1
r
I notice my /etc/resolv.conf on the other nodes is different
Yes did that the old mac address is gone
x
if you use the arp utility from fedora do you see the host in the list
r
what is the foramt of the command ?
arp gives me nothing reconisable
x
im on ubuntu but think arp -a should work
r
123 = node 3, 122=node 2 and 121= node1
x
mmm mDNS issue, Im not familiar with this, but can you clear/flush the DNS cache
r
let me see
x
also I’d delete the message above with your MAC address… You can’t be to careful :-).
r
I don't have that option on the router
thanks
It's ATT so they don't let you touch the DNS
x
oh ok, you could manually add the hosts to your hosts file on your fedora and nodes, a little bit of a pain, but would work around not having access to DNS configuration
r
Yeah I have put all of the nodes into the hosts file of each node I can try that, it's just that it works auotmatically for the other nodes I think its a mulicast issue
thanks for the help
x
ok, good luck
r
I noticed in the /etc/systemd/resolved.conf that the commented out mdns=no on node 1 and yes on the others, trying that
x
Just done a little reading on multicast DNS, very cool, so yes hopefully the isssue
r
found it on the other nodes they are running avahi deamon
sudo apt install -y avahi-daemon
worked
3 Views