https://turingpi.com logo
#│forum
BMC 2.0.5 Node OS flash via UI - works great!
# │forum
d

dustyesky5167

12/10/2023, 2:26 AM
Just thoght I'd give some positive feedback to all who have put in clealry an immense amount of work into the BMC firmware. Apart from all of the background changes, the introduction of being able to flash the node OS from the BMC UI is a big step forward. I upgraded the BMC yesterday which went really well (other than some weird glitch with the BMC UART - yet to be fully understood and seemingly now DOA). Then I realised that the Pi OS version on my 4 CM4s had changed so I decided to try out the OS flash via the GUI. It worked really well! I flashed my 4 eMMC CM4s with no problem at all. Way less palava than the original USB-based flash process. Awesome work, BMC devs!
n

ncasaux_96421

12/17/2023, 12:39 PM
I recently updated the BMC to v2.0.5 and successfuly managed to flash a CM4 node with the UI. Worked perfectly! @User , is possible to use the
tpi
api to flash a node with an image which would be located on my computer (like we can do now with the UI) ?
s

svenrademakers

12/17/2023, 1:26 PM
This should be no problem, the command for this should be
tpi flash --image-path /your/image
.make sure you have the latest version of the tpi installed on your computer. https://firmware.turingpi.com/tpi should have the latest version.
n

ncasaux_96421

12/17/2023, 1:41 PM
Oh ok, I can install the `tpi `api on my local computer. Thanks @svenrademakers , I'll try that 🙂
I had to add
[trusted=yes]
in line
deb [trusted=yes] https://firmware.turingpi.com/tpi/debian ./
to allow update of the repo (I'm using Ubuntu, not sure if it's related...) I could run some
tpi
commands successfully!
s

svenrademakers

12/17/2023, 4:13 PM
yes your right i didnt add all the mandatory files yet to the debian repo. glad to hear its working
c

carina.akaia.io

01/04/2024, 9:21 PM
Has anyone tried this for Nvidia modules?
u

_dhanos_

01/04/2024, 9:37 PM
Won't work. Only rpi-boot-compatible solutions so probably only CM4 and RK1 for now
5 Views