https://turingpi.com logo
#│forum
cannot flash OS on to CM4
# │forum
j

jimmymcboatface

11/27/2023, 5:55 PM
Hi all, I can't get rpiboot to pick up on the CM4 EMMC storage. Connected up via a male to male USB cable, made sure the CM4 module is in slot 2, ran sudo ./rpiboot -d msd but when I start up the node 2 in device mode, nothing happens. Help! https://cdn.discordapp.com/attachments/1178755891642765444/1178755982520754327/Screenshot_2023-11-27_at_17.52.46.png?ex=65774d0e&is=6564d80e&hm=3f8dc5b78ae334187efbef1890df77f4f5b93d42aa530307c333357ae3561d73&
s

scienceman.

11/27/2023, 6:48 PM
Try in node 3 or 4
j

jimmymcboatface

11/27/2023, 7:12 PM
I have done, tried em all 😦
All in device mode and node turned on via the gui
ok, so it randomly started working after 3 restarts and flicking the node on/off a few times in the gui. Not exactly confidence inspiring, but Im in. Thanks for the reply.
u

_dhanos_

11/28/2023, 3:57 PM
Make sure to turn the module power off, then set the USB mode then power the module on again, otherwise it won;t run into the flashing mode.
u

.rpitre

12/10/2023, 9:43 PM
I tried this many, many times on all 4 nodes and it never works. No quit sure what to do next ...
y

yann7541

12/12/2023, 12:07 PM
I am facing also an issue with my CM4. I could successfully flash it (at least the checksum resulted that way) but when starting the node, it is not powering up networking, i.e., does not who up. I also have ssh touched and UART settings tried but the latter do not even show a login. Anyone any clue?
3 Views