Xavier NX flashing
# │forum
d
-
Here @incidrthreat
i
d
So, this process might be different from both Jetson nano and Orin modules since it's old generation but uses ubuntu 20.04 and can be flashed with the SDK Manager
i
if I had a B01 Nano and an Orin, I'd test both. It seems like it would be similarly as straight forward as the Xavier
d
Orin was far from being straightforward and there's a reason for that, plus Nvidia doesn't care about 3rd party carrier boards. If they changed their minds, that means we can use the SDK Manager to flash them. Jetson Nano is as easy as Xavier NX, you just need Ubuntu 18.04, and it'll flash older firmware.
n
Just sharing my experience here, maybe someone will benefit from this information. Flashing the Xavier NX module with the Turing Pi board is indeed not difficult, though I could not finish the process over the pas two days because
apt update
would not work properly on the Jetson. This may have been an issue with NVidia's repo. Today it worked, at last. I flashed the OS on an nvme ssd attached to the Jetson, using a Ubuntu 20.04 VM in Windows. To configure the VM, I followed the instructions in the Orin NX/Nano section in the Turing Pi docs. I then connected the Turing Pi to my computer using a USB-A to USB-A cable, and after doing
tpi usb --node 2 flash
and
tpi power on --node 2
on the Turing Pi, the Jetson was immediately detected in the VM (
lsusb
). To flash the OS, I used
sdkmanager
that can be downloaded from NVidia's website. I chose Jetpack 5.1.3. The flashing process is pretty straightforward and it worked well, but in my case only for the Jetson OS, it would not work for the SDK's and Cuda tools and such. This may be because of the aforementioned
apt update
issues I experienced. In any case, you can just install the Jetson OS and leave the other components un-checked. These optional (yet vital) packages can be installed later using
apt install nvidia-jetpack
. When the OS install was finished (this took a long time), I did
tpi power off --node 2
,
tpi usb --node 2 device
, and
tpi power on --node 2
. I monitored the boot process via
microcom -s 115200 /dev/ttyS1
. It took a few minutes and then I was able to login with the credentials I set up in
sdkmanager
. After booting, I updated everything and installed the optional packages using
sudo apt update && sudo apt install upgrade -y && sudo apt install nvidia-jetpack -y && sudo apt autoremove -y
. I tried some of the tutorials at https://www.jetson-ai-lab.com/, and the module seems to work quite well. Looking forward to getting started with my own AI edge projects! 🙂
It should be possible to do this without a VM too, in WSL. Someone did it with a Jetson Mate board (https://xaviergeerinck.com/2023/03/21/building-your-own-ai-cluster-with-jetson-mate/). I will receive another Xavier NX module in the coming weeks, will try this as well.
t
I too have used the latest JetPack 6. The Jetson Xavier's 16GB of eMMC is only large enough to hold L4T/Jetson Linux. You must install to NVMe, or a larger device (SATA, USB, ...) if you want the runtime and development tools.
o
@naamval for flashing the xavier nx were you able to use the nvme option in the sdkmanager? Or if not what process did you use to expand to the nvme drive after the initial flashing to the emmc? Sidenote: It would be great to have the flashing process to emmc/nvme on the turing pi website expanded with a working instruction for the xavier nx (16gb) emmc modules
2 Views