Turing Pi 1: CM3 availability (specifically CM3E &...
# │forum
My TP1 has two CM3+ at the moment. I've since ordered a used CM4S off eBay and I'm curious about availability on CM3, CM3E, and CM4S otherwise. Has anyone used CM3E or CM4S on their Turing Pi 1?
@geerlingguy any news from your recent trip?
I've seen a few squeaking out here and there. That line wasn't running the day I was there, they were doing 3 B+
Have you used any CM4S or CM3E? If so how do they compare to CM3?
CM4S is a bit faster. Works okay otherwise.
Would the CM4S work in the TP1?
They're made to replace CM3, so they should
Hopefully 🤞 🤞
I did pick up a CM4S on eBay for my TP1... installed DietPi, but having boot issues (turns out I didn't, but I am having flashing issues)
Copy code
Raspberry Pi - 1GB
bootloader: 507b2360 2022/04/26
board: a03150 f8c1131b b8:27:eb:c1:13:1b
boot: mode BCM-USB-MSD 5 order f51 retry 0/128 restart 7/-1
SD: card not detected
part: 0 mbr (0x00:00000000 0x00:00000000 0×00:00000000 0x00:00000000]
net: down ip: sn: gw:
tfp: 00:00:00:00:00:00

Boot mode: SD (01) order f5
Trying partition: 0
Trying partition: 0
Trying partition: 0
Trying partition: 0
Failed to open device: 'sdcard* (cmd 6160010 status 1fef9002)
Boot mode: BCM-USB-MSD (05) order f
USB2 [1] 000206e1 connected
USB2 [1] 00200e03 connected enabled
USB2 root HUB port 1 init
HUB [01:00] 2.00 000000:01 init port 1 speed 3
USB MSD stopped. Timeout: 25 seconds
Boot mode: RESTART (0f) order 0
it has an 8GB eMMC, but doesn't seem to boot, any advice?
I'm curious where to go from here.
Have you tried Raspberry Pi OS?
not yet... I'll try that
hmmm, it won't show up in Raspberry Pi Imager anymore... boot/flash jumper is in the correct position?
ok, my problem is more fundamental
- I forgot to use
sudo ./rpiboot
(sigh) 😭
sudo ./rpiboot
doesn't seem to work, it stops at:
Copy code
Waiting for BCM2835/6/7/2711...
Does the CM4S flash the same as the CM3? I'm following the
instructions and it hangs at
Waiting for BCM2835/6/7/2711
rpiboot -d .\msd
might be necessary, but it should see the module anyway. If it does not see it it's either not in the flashing mode, or something's wrong somewhere else in teh chain. But you flashed other modules already so this part should not be a problem.
I tried the
too… 😭
I put one of my existing CM3 in node 1 position and it still was not seen (for flash-ing, for boot it’s fine)
This is odd. I wish I new more about this board to try to help you. You are having so many issues with this 😐
I removed the CM4S and put one of my CM3’s back in…. it isn’t detected either (in flash mode) in the TP1 at the moment.
What’s the least expensive option for a standalone device to flash CM1/3/3+ with eMMC?
The original I/O board? The Waveshare PoE I/O board?
I probably shouldn’t be looking for spending money to fix my problems, but for-the-moment, the TP1 doesn’t seem to be cooperating in mounting any of my CM1/3/3+ for flashing 😦
Apologies, my posts here starting on June 15 should have been in a thread under tech-support… I’ll create one there
I successfully fixed my issue by flashing using a different TP1. I'd rather know why using my main one didn't work, but I'll take success in any case.